WISEflow - Update browser

WISEflow requires a modern browser in order to run. Update to a newer browser to gain access.

Update browser

Aarhus BSS has access to WISEflow through the following logins


Help and guidance to the use of WISEflow can be found here

It is recommended to upgrade to one of the following browsers before using WISEflow.

About browsers

WISEflow Oak 2.0.0
Support & Feedback
© Copyright UNIwise 2012-2015